Bienvenue, Invité. Merci de vous connecter ou de vous enregister.

Auteur Sujet: [Mod] expedition  (Lu 17650 fois)

roms0406

  • Dev OGSteam
  • Complètement accro !
  • ***
  • Messages: 300
  • Karma: +3/-0
Re : [Mod] expedition
« Réponse #60 le: 10 août 2015, 13:32:21 »
Bon j'ai trouvé avec firefox, et j'ai eu une expé à 1.050.000 métal
Seul 1.050 métal sont enregistrés dans ogspy, voici le détail du plug :

- Mods éxécutés
Erreur :
- Informations de débogage
Données envoyées : toolbar_version=2.6.1&toolbar_type=FF&mod_min_version=2.4.1&ogame_player_name=EVH&ogame_player_id=181873&user=EVH&password=PSWD&univers=http://s108-fr.ogame.gameforge.com&data[date]=1439172200&data[type]=expedition&data[coords]=5%3A221%3A16&data[content]=Sur%20cette%20plan%C3%A8te%20compl%C3%A8tement%20isol%C3%A9e%2C%20nos%20chercheurs%20ont%20d%C3%A9couvert%20des%20champs%20de%20ressources%20facilement%20exploitables%20et%20ont%20p%C3%BB%20collecter%20un%20nombre%20non%20n%C3%A9gligeable%20de%20mati%C3%A8res%20premi%C3%A8res.L%60attaquant%20obtient%20M%C3%A9tal%201.050.000.&type=messages&lang=fr&dev=1
URL du serveur : http://ogspy.wawafuck.com/mod/xtense/xtense.php
URL complète : http://ogspy.wawafuck.com/mod/xtense/xtense.php?toolbar_version=2.6.1&toolbar_type=FF&mod_min_version=2.4.1&ogame_player_name=EVH&ogame_player_id=181873&user=EVH&password=PSWD&univers=http://s108-fr.ogame.gameforge.com&data[date]=1439172200&data[type]=expedition&data[coords]=5%3A221%3A16&data[content]=Sur%20cette%20plan%C3%A8te%20compl%C3%A8tement%20isol%C3%A9e%2C%20nos%20chercheurs%20ont%20d%C3%A9couvert%20des%20champs%20de%20ressources%20facilement%20exploitables%20et%20ont%20p%C3%BB%20collecter%20un%20nombre%20non%20n%C3%A9gligeable%20de%20mati%C3%A8res%20premi%C3%A8res.L%60attaquant%20obtient%20M%C3%A9tal%201.050.000.&type=messages&lang=fr&dev=1
Réponse du plugin : ({"new_messages": 0,"type": "messages","calls": {"success": [],"warning": [],"error": ["eXpedition"]},"execution": 16.02})
 

pitch314

  • Dev OGSteam
  • Complètement accro !
  • ***
  • Messages: 463
  • Country: 00
  • Thanked: 3 times
  • Karma: +7/-0
Re : [Mod] expedition
« Réponse #61 le: 10 août 2015, 21:57:35 »
Je confirme alors :
Le problème de viens pas de Xtense mais de l'analyse du message par le mod eXpedition.
Il doit avoir une mauvaise règle de lecture des nombres.
mods  : "Production", "Build.Tech HOF"(bthof) et "Temps de vol"
OGSpy v3
OGSpy v5 (gestion BDD et sécurité)
 

rhodan

  • Prend ses marques
  • **
  • Messages: 46
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #62 le: 24 avril 2016, 00:41:32 »
Bonsoir bonsoir ...

Pour ce qui me concerne, pas de remonté des expéditions

Configuration:
Chrome 49.0.2623.112 m mais c'est pareil avec d'autres versions (même la 50.0)
Xtense Chrome 2.6.9.18

Serveur Ogspy:
Ogspy 3.2.0
mod xtense 2.6.6
mod expédition 1.1.1

Confguration Xtense mod actifs:
#   Nom/version du Mod          Type de données           Status du mod   Status du lien   
4   Champs de ruines (1.8.4)       Systèmes solaires          Mod actif            Lien actif   
1   eXpedition (1.1.1)                   Rapports d'expeditions   Mod actif            Lien actif   
6   flottes (1.1.1)                           Flotte                           Mod actif            Lien actif   
2   Gestion des attaques (1.1.2)   Rapports de combat           Mod actif            Lien actif   
3   Gestion des attaques (1.1.2)   Rapports de recyclage   Mod actif           Lien actif   
5   Qui Me Sonde (1.8.2)           Espionnages ennemis   Mod inactif   Lien actif    ==> mod désactivé pour éviter qu'il n'empiète sur le mod eXpedition

Message dans la console de Chrome avec le mod Qui Me Sonde désactivé:
Xtense says : Message court Expédition envoyé
xtense.user.js:93 Xtense says : ID Message court : 7789742
xtense.user.js:93 Xtense says : Message court Expédition détecté :
xtense.user.js:93 Xtense says : sending toolbar_version=2.6.9.18&toolbar_type=GM-GC&mod_min_version=2.5.1&user=Usul&password=9531548e4cfef10579701a2447002794&univers=https://s126-fr.ogame.gameforge.com&data[type]=expedition&data[coords]=1%3A…%20Probabilit%C3%A9%20de%20contre-espionnage%20%3A%200%20%25&type=messages to https://bio-zag.ogspy.net/ogspy/mod/xtense/xtense.php from https://s126-fr.ogame.gameforge.com
xtense.user.js:93 Xtense says : Message court Expédition envoyé
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : setStatus : Page de messages détectée
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : setStatus : Page de messages détectée
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : setStatus : Page de messages détectée
xtense.user.js:93 Xtense says : Traitement d'un message detaille
e655f75….js:84 load subtabs-nfFleet22
e655f75….js:84 These is no function defined for action:  subtabs-nfFleet22
xtense.user.js:93 Xtense says : Response: {"new_messages":0,"type":"messages","execution":"14.67"}
xtense.user.js:93 Xtense says : setStatus : [14.67 ms] Message correctement envoyé
xtense.user.js:93 Xtense says : Response:
xtense.user.js:93 Xtense says : setStatus : Réponse du plugin vide
xtense.user.js:93 Xtense says : Response:
xtense.user.js:93 Xtense says : setStatus : Réponse du plugin vide
xtense.user.js:93 Xtense says : Response:
xtense.user.js:93 Xtense says : setStatus : Réponse du plugin vide
xtense.user.js:93 Xtense says : Response:

Message dans la console de chrome avec le mod Qui Me Sonde activé
xtense.user.js:93 Xtense says : ID Message court : 7789742
xtense.user.js:93 Xtense says : Message court Expédition détecté :
xtense.user.js:93 Xtense says : sending toolbar_version=2.6.9.18&toolbar_type=GM-GC&mod_min_version=2.5.1&user=Usul&password=9531548e4cfef10579701a2447002794&univers=https://s126-fr.ogame.gameforge.com&data[type]=expedition&data[coords]=1%3A…%20Probabilit%C3%A9%20de%20contre-espionnage%20%3A%200%20%25&type=messages to https://bio-zag.ogspy.net/ogspy/mod/xtense/xtense.php from https://s126-fr.ogame.gameforge.com
xtense.user.js:93 Xtense says : Message court Expédition envoyé
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : setStatus : Page de messages détectée
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : setStatus : Page de messages détectée
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : setStatus : Page de messages détectée
xtense.user.js:93 Xtense says : Traitement d'un message detaille
e655f75….js:84 load subtabs-nfFleet22
e655f75….js:84 These is no function defined for action:  subtabs-nfFleet22
xtense.user.js:93 Xtense says : Response: {"new_messages":0,"type":"messages","call_messages":[{"mod":"Qui Me Sonde","message":"L'espionnage de 5:244:8 () du 04-22 20:41:27 existe du00e9ju00e0.","type":"warning"},{"mod":"Qui Me Sonde","message":"Un total de 0 espionnages ont &ecute;t&ecute; enregistr&ecute;s","type":"success"}],"calls":{"success":["Qui Me Sonde"],"warning":[],"error":[]},"execution":"11.19"} =======> alors que je suis dans l'onglet Expédition de la page messages
xtense.user.js:93 Xtense says : setStatus : [11.19 ms] Message correctement envoyé
xtense.user.js:93 Xtense says : Response:
xtense.user.js:93 Xtense says : setStatus : Réponse du plugin vide
xtense.user.js:93 Xtense says : Response:
xtense.user.js:93 Xtense says : setStatus : Réponse du plugin vide
 

DarkNoon

  • Administrator
  • Complètement accro !
  • *****
  • Messages: 2629
  • Country: fr
  • Karma: +15/-2
  • Retraité Actif
    • Hébergement de serveurs OGSpy
Re : [Mod] expedition
« Réponse #63 le: 24 avril 2016, 01:04:30 »
J'ai déjà croisé ce bug. Quel était le résultat de l'expédition ?
Héberger votre OGSpy : Hébergement
Réseaux Sociaux OGSteam :Facebook
 

rhodan

  • Prend ses marques
  • **
  • Messages: 46
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #64 le: 24 avril 2016, 21:08:57 »
Bon je n'ai mis la trcae que d'un seul des messages expéditions,
mais ils donnent tous le même résultat que ce qui a été mis ci-dessus

Que ce soit rien trouvé, ou récup de métal ou cristal ou deut, ou de l'AM, pour les rencontres avec les aliens ou les pirates qui provoque un combat, seul celui contre les aliens plantent de cette manières

Ensuite dans les RC
Rencontre d'Aliens ==> Message de RC
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : Message Long messageid : 7830708
xtense.user.js:93 Xtense says : Message Long combatreportId : 1108187
xtense.user.js:93 Xtense says : Response: <table align=center border=1>
<tr><td class='c' colspan='3'>Database MySQL Error</td></tr>
<tr><th colspan='3'>ErrNo::  </th></tr>
<tr><th colspan='3'><u>Query:</u><br>INSERT INTO ogspy_round_attack (
                            `id_rcround`, `player`, `coordinates`, `Armes`, `Bouclier`, `Protection`, `PT`, `GT`, `CLE`, `CLO`, `CR`, `VB`, `VC`, `REC`, `SE`, `BMD`, `SAT`, `DST`, `EDLM`, `TRA`
                        ) VALUE (
                            '294', 'Aliens', '1:239:16', '160', '160', '160', '0', '38', '0', '5', '0', '0', '0', '0', '5', '0', '0', '0', '0', '0'
                        )</th></tr>
</table>

xtense.user.js:93 Xtense says : setStatus : Impossible de récupérer les données envoyées par le plugin, verifiez que votre hebergeur ne rajoute pas de la pub, ce qui peut provoquer cette erreur.

Et pour le même envois mais côté journal du serveur OGSpy
)
'294', 'Aliens', '1:239:16', '160', '160', '160', '0', '38', '0', '5', '0', '0', '0', '0', '5', '0', '0', '0', '0', '0'
) VALUE (
`id_rcround`, `player`, `coordinates`, `Armes`, `Bouclier`, `Protection`, `PT`, `GT`, `CLE`, `CLO`, `CR`, `VB`, `VC`, `REC`, `SE`, `BMD`, `SAT`, `DST`, `EDLM`, `TRA`
  • => INSERT INTO ogspy_round_attack (

fonction => sql_query
ligne => 824
file => /var/www/vhosts/bio-zag.ogspy.net/httpdocs/ogspy/mod/xtense/xtense.php
[1]
)
'294', 'Aliens', '1:239:16', '160', '160', '160', '0', '38', '0', '5', '0', '0', '0', '0', '5', '0', '0', '0', '0', '0'
) VALUE (
`id_rcround`, `player`, `coordinates`, `Armes`, `Bouclier`, `Protection`, `PT`, `GT`, `CLE`, `CLO`, `CR`, `VB`, `VC`, `REC`, `SE`, `BMD`, `SAT`, `DST`, `EDLM`, `TRA`
  • => INSERT INTO ogspy_round_attack (

fonction => DieSQLError
ligne => 164
file => /var/www/vhosts/bio-zag.ogspy.net/httpdocs/ogspy/includes/mysql.php

) - Erreur n°
'294', 'Aliens', '1:239:16', '160', '160', '160', '0', '38', '0', '5', '0', '0', '0', '0', '5', '0', '0', '0', '0', '0'
) VALUE (
`id_rcround`, `player`, `coordinates`, `Armes`, `Bouclier`, `Protection`, `PT`, `GT`, `CLE`, `CLO`, `CR`, `VB`, `VC`, `REC`, `SE`, `BMD`, `SAT`, `DST`, `EDLM`, `TRA`
24/04/2016 20:59:53 : Erreur critique mysql - Req : INSERT INTO ogspy_round_attack (


Rencontre avec des pirates la ca passe comme un RC normal
xtense.user.js:93 Xtense says : Traitement d'un message detaille
xtense.user.js:93 Xtense says : Message Long messageid : 7824726
xtense.user.js:93 Xtense says : Message Long combatreportId : 1107489
xtense.user.js:93 Xtense says : Response: {"new_messages":0,"type":"rc","calls":{"success":["Gestion des attaques"],"warning":[],"error":[]},"execution":"10.57"}
xtense.user.js:93 Xtense says : setStatus : [10.57 ms] Rapport de combat envoyé

 

DarkNoon

  • Administrator
  • Complètement accro !
  • *****
  • Messages: 2629
  • Country: fr
  • Karma: +15/-2
  • Retraité Actif
    • Hébergement de serveurs OGSpy
Re : [Mod] expedition
« Réponse #65 le: 24 avril 2016, 22:42:13 »
Donc c'est reconnu comme un RC... Je vais voir comment améliorer çà :-)
Héberger votre OGSpy : Hébergement
Réseaux Sociaux OGSteam :Facebook
 

roms0406

  • Dev OGSteam
  • Complètement accro !
  • ***
  • Messages: 300
  • Karma: +3/-0
Re : [Mod] expedition
« Réponse #66 le: 24 avril 2016, 23:14:42 »
Tu as essayé avec le mod que je t'ai envoyé ??

Chez moi la remontée d'infos est correcte
 

rhodan

  • Prend ses marques
  • **
  • Messages: 46
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #67 le: 25 avril 2016, 21:13:48 »
répondu en MP ..

mais non ca remonte pas avec ton kit désolé.

au pire j'essaierais sur le même hébergeur que toi hostinfo, je voulais tester la v3 alpha sur cette hébergeur mais toujours en version gratuite.
 

celticwolf

  • Bleusaille
  • *
  • Messages: 8
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #68 le: 26 avril 2016, 14:58:24 »
Bonjour a tous

Je profite que vous êtes en train de travailler sur ce mod pour vous prévenir que chez moi les vaisseaux gagnés ne sont pas remonté.

Chez vous aussi? ou il y a une erreur de mon côté?
 

roms0406

  • Dev OGSteam
  • Complètement accro !
  • ***
  • Messages: 300
  • Karma: +3/-0
Re : [Mod] expedition
« Réponse #69 le: 26 avril 2016, 22:24:58 »
J'ai rien en MP ....

Et je ne suis pas hébergé sur hostinfo non plus ^^

Concernant le mod, chez moi tout est remonté, avec une version légèrement modifié que j'avais donné à rhodan
Donc celticwolf si tu veux tester demande moi en mp
 

celticwolf

  • Bleusaille
  • *
  • Messages: 8
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #70 le: 27 avril 2016, 08:38:48 »
Je t'est envoyé un MP ;)
 

roms0406

  • Dev OGSteam
  • Complètement accro !
  • ***
  • Messages: 300
  • Karma: +3/-0
Re : [Mod] expedition
« Réponse #71 le: 27 avril 2016, 14:02:49 »
Essaye en remplaçant ton mod expedition par celui ci
 

celticwolf

  • Bleusaille
  • *
  • Messages: 8
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #72 le: 27 avril 2016, 15:38:12 »
Je vient de l'installer sur mon serveur.

Le nombre de vaisseaux est bien remonter désormais, les quantités de ressources ont l'air correct.
Seul les expédition échoué n'ont pas l'air d'être classé.

bravo pour les modifications :)
 

roms0406

  • Dev OGSteam
  • Complètement accro !
  • ***
  • Messages: 300
  • Karma: +3/-0
Re : [Mod] expedition
« Réponse #73 le: 27 avril 2016, 21:42:09 »
Ha ça me rassure

Les fails et les marchands ouep ça marche pas il me semble mais le reste passe au moins

Rassuré de voir que c'est pas que chez moi que ça marche ;)
 

celticwolf

  • Bleusaille
  • *
  • Messages: 8
  • Karma: +0/-0
Re : [Mod] expedition
« Réponse #74 le: 27 avril 2016, 21:45:12 »
Pour les marchand je n'avais pas d’expédition en ramener un sous la main, je sais qu'il était bien remonter avant.

tu pense qu'il serait possible de rajouter un truc?